WP Security: 21 plugin vulnerabilities in January 2019

WP Security: 21 plugin vulnerabilities in January 2019

WP Security bulletin – January 2019

At your next scheduled WordPress Maintenance, be advised for your WP Security about the latest 21 vulnerabilities in WordPress plugins identified and reported publicly. As these vulnerabilities are disclosed, when you use one (or more) of these outdated plugins – your risking serious WordPress breaches to your site(s).


  • Google XML Sitemaps
    • Authenticated Cross-Site Scripting (XSS) reported by Javier Casares, (@JavierCasares). A security issue related to escaping external URLs and another security issue related to option tags in forms.
      • WP Security recommendation: immediately upgrade to version 4.1.0 to fix the vulnerability.

  • Two Factor Authentication
    • Disable Two Factor Authentication CSRF reported by Martijn Korse (bitnesswise.com) and Ryan Dewhurst (RIPS Technologies). A logged-in CSRF vulnerability, due to a missing nonce check, if an attacker was able to persuade a personally-targeted victim who was currently logged in to their WordPress account to visit a personally-crafted (for the individual victim) page in the same browser session, then the attacker would be able to de-activate two-factor authentication for the victim on that WordPress site (thus leaving the targetted account protected by the user’s password, but not by a second factor – the absence of a request for a TFA code would be apparent on the user’s next login). This vulnerability was inherited from the original “Two Factor Auth” plugin that this plugin was forked from, and so is present in all versions before this one.”
      • WP Security recommendation: immediately upgrade to version 1.31.3 to fix the vulnerability.
  •  

    Our only security is our ability to change. ~ John Lilly


  • spam-byebye
    • Cross-Site Scripting (XSS) reported by Ryan Dewhurst (RIPS Technologies). Cross-site scripting vulnerability in WordPress plugin spam-byebye 2.2.1 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
      • WP Security recommendation: immediately upgrade to version 2.2.2 to fix the vulnerability.

  • User Registration
    • Authenticated Cross-Site Scripting (XSS) reported by Ryan Dewhurst (RIPS Technologies). WordPress User Registration plugin version 1.5.3 suffers from a cross-site scripting vulnerability.
      • WP Security recommendation: immediately upgrade to version 1.5.6 to fix the vulnerability.

  • Wise Chat
    • Reverse Tabnabbing reported by Ryan Dewhurst (RIPS Technologies). The WordPress Plugin called Social Network Tabs, made by the company Design Chemical, is leaking twice the Twitter access_token, access_token_secret, consumer_key and consumer_secret oThe Wise Chat plugin before 2.7 for WordPress mishandles external links because “rendering/filters/post/WiseChatLinksPostFilter” php file omits noopener and noreferrer.
      • WP Security recommendation: immediately upgrade to version 2.7 to fix the vulnerability.

  • Yet Another Stars Rating
    • PHP Object Injection reported by Ryan Dewhurst (RIPS Technologies). An unauthenticated PHP object injection in the “Yasr – Yet Another Stars Rating” WordPress plugin introduces a starting point for RCE and similar high-severity vulnerabilities. A shortcode provided by the plugin passes Cookie data without any filtering to PHPs unsafe “unserialize()” function.
      • WP Security recommendation: immediately upgrade to version 1.8.7 to fix the vulnerability.

  • Health Check & Troubleshooting
    • Authenticated Path Traversal reported by Julien Legras (Synacktiv) and siliconforks. Arbitrary file viewing through the integrity file actions.
    • Authenticated Lack of Authorisation reported by Julien Legras (Synacktiv) and siliconforks. Site status was available to any user with a subscriber role or higher on a site.
      • WP Security recommendation: immediately upgrade to version 1.2.4 to fix both vulnerabilities.
  •  

    Protect your WordPress: BEFORE IT’S TOO LATE! You will also protect your customers, your reputation and your online business!

    The following WordPress plugin vulnerabilities are extremely dangerous since the active installations are in the millions OR the reported vulnerabilities were never patched. The potential risk goes up each day as more and more bad intended persons find out about these vulnerabilities.

    Get Healthy, Stay Healthy: A healthier online business starts today and it begins with you!

    Summary
    WP Security: 21 plugin vulnerabilities in January 2019
    Article Name
    WP Security: 21 plugin vulnerabilities in January 2019
    Description
    At your next scheduled WordPress Maintenance, be advised for your WP Security about the latest 21 vulnerabilities in WordPress plugins identified and reported publicly. As these vulnerabilities are disclosed, when you use one (or more) of these outdated plugins - your risking serious WordPress breaches to your site(s).
    Author
    Publisher
    owl power EUROPE

Related Posts

Leave a comment

Do NOT follow this link or you will be banned from the site!